A tried ritual for Naamah without the proper tools and what happened

So a few weeks ago, family was away and I believed I gathered the tools for a ritual to Naamah. I performed the ritual, but stupidly did not know lancing devices and lancets were different things. So I did the ritual without blood. I didn’t believe the ritual worked, but I chalked it up as a rehearsal. Next day, my xbox couldn’t connect to the wifi. Its been on and off sense then. Any thoughts?

1 Like

Yep. You might want to bust out a lancet and complete that part, and see what happens. It could be that you did indeed miss something important, or that you are causing the interference by focusing on the fact that you forgot something.

1 Like

may i ask what are you intentions for naamah?

Growth, opportunity to face fears

whats the ritual?


Naamah always appreciates semen (and/or female juices) more than blood. Just trust me on that one.


I have found some vials lying around. I suppose I can fill one a bit.

At the moment I’m trying to train my Astral senses.